[SOLVED]* Sysprep - Fatal error occurred while trying to sysprep the machine

Posted on: Sep 10 2012 Category :Windows > Windows7installsetup Views: 14436 | Subscribe

Solved : Go to Solution

 

On the 4th attempt to sysprep a Windows 7 Enterprise system, I get the dreaded, 'A fatal error occurred while trying to sysprep the machine.' 

The setuperr.log shows:2010-08-04 13:57:58, Error      [0x0f0073] SYSPRP RunExternalDlls:Not running DLLs; either the machine is in an invalid state or we couldn't update the recorded state, dwRet = 312010-08-04 13:57:58, Error      [0x0f00ae] SYSPRP WinMain:Hit failure while processing sysprep cleanup external providers; hr = 0x8007001fI've seen articles referring to the Windows Software Licensing Rearm program may have issues running more than three times in a single Windows image and to add <SkipRearm>1</SkipRearm> in the /unattend file...  but this did not help.  The Windows Media Player Network Sharing Service has also been disabled which is often referred to in other posts.

The KB article: http://support.microsoft.com/kb/947212/en-us indicated that the resolution is to re-create the image for the machine... This is very frustrating. I'm hoping that there is a better resolution???

How do you sysprep a machine more than three times to avoid this error?

Thanks!! 

930193


Run Command Prompt as Administrator. and enter the following command.

slmgr /dlv

Run regedit got to this key HKEY_LOCAL_MACHINE\SYSTEM\Setup\Status\SysprepStatus and set value to 7. Run sysprep again.
If the problem is not resolved , then run cmd.exe as Administrator. and enter the following commands

msdtc -uninstall

msdtc -install








This posting is provided AS IS with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

Get email updates. Virus Removal Tips, News, How to, Threat Alerts.

Leave a comment!

Get Answers, News and other Updates