Welcome to Ebugg-i.com

Thanks for coming to Ebugg-i.com.

Ad blocker detected


Our website is made possible by displaying online advertisements to our visitors. We need to pay our bills (hosting charges) and we can't do that for free. Please consider supporting us by disabling your ad blocker on our website and whitelist our website.
Please disable ad blocker and reload this web page
Close this message

No sound, done everything still no sound

Posted on: Jun 26 2014 Category :Linux > Ubuntu Views: 1015 | Subscribe


Brand new homebuilt machine, MSI MS-7721 w/ AMD A8-6600K APU with Radeon(tm) HD Graphics. Ubuntu 13.10 kernel 3.11.0-23-generic. Pulled my hair out trying to get the Realtek USB WiFi working. Now with not getting sound working I have no hair left. So https://help.ubuntu.com/community/SoundTroubleshooting says Warning As of 2012, much of the information on this page is outdated. Please refer to the official sound debugging guide and Ubuntu Audio Development team's pages for more up-to-date information.Ruh roh! Okay, we go to the official sound debugging guide. That tells me to make sure I have the latest alsa drivers so I go to yet another page wiki.ubuntu.com/Audio/UpgradingAlsa which says:Make sure you only have one override of ALSA drivers installed at a time. Make sure you uninstall the previous override before trying a new one, otherwise it is unclear which version will take precedence. I have no idea what that means. Okay back to the referring page which then sends me to wiki.ubuntu.com/Audio/HDAGeneric I follow the instructions:Code:Erewhon:~$ grep "Codec:" /proc/asound/card*/codec*/proc/asound/card0/codec#0:Codec: ATI ID aa01/proc/asound/card1/codec#0:Codec: Realtek ALC887-VDAccording to that page, the "ATI ID aa01" is not supported while the Realtek is. OK. Plodding on I'm sent to alsaproject.org. Now at this point I can'tdecie whether I'm in the Garden of Forking Paths or the Minotaur's labyrinth. Whatever, I want some sound! So here I am at alsaproject.org. I follow a link Is my soundcard supported I don't see any Realtek listing so I hit the Intel listing but I have no idea what I'm looking at/for. Okay then, let's go to [/URL] alsaproject.org SoundcardTesting which instructs me to Code:aplay -vv /usr/share/sounds/alsa/Noise.wav Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, MonoALSA PulseAudio PCM I/O PluginIts setup is: stream : PLAYBACK access : RW_INTERLEAVED format : S16_LE subformat : STD channels : 1 rate : 48000 exact rate : 48000 (48000/1) msbits : 16 buffer_size : 24000 period_size : 6000 period_time : 125000 tstamp_mode : NONE period_step : 1 avail_min : 6000 period_event : 0 start_threshold : 24000 stop_threshold : 24000 silence_threshold: 0 silence_size : 0 boundary : 6755399441055744000##### + | 10%. Umm, okay? but not a single peep was heard. *whines softly* At this point I don't know where I am much less where I've been. Some of the other things I did, recommended at various pages far and wide aross the great interwez. Code:Erewhon:~$ sudo aplay -l**** List of PLAYBACK Hardware Devices ****card 0: HDMI [HDA ATI HDMI], device 3: ID aa01 Digital [ID aa01 Digital] Subdevices: 1/1 Subdevice #0: subdevice #0card 1: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog] Subdevices: 1/1 Subdevice #0: subdevice #0Gee. At this point I will mention that in the BIOS(UEFI) I can see where the speakers are plugged in, whether front or back so I'm pretty sure I got the harnesses and jumpers and stuff in their right places. Sowatch what happens when I move my (known good) speakers from the rear jack to the front headphone jack So alsamixer is detecting the speakers. Following the advice of various people far and wide across teh great interwebz I did some other stuff. So here are some screen caps: pavucontrol: At some point I was told to Code:wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && bash alsa-info.sh which output a shitton of info. I have no idea what the relevant parts are. Then I saw to do Code:Erewhon:~$ LC_ALL=C cat /proc/asound/card*/codec#* | LC_ALL=C fgrep --before-context=4 --after-context=1 "Subsystem Id" Erewhon:~$ LC_ALL=C lspci -vvnn | LC_ALL=C fgrep --after-context=1 "Audio device" 00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller [1002:9902] Subsystem: Micro-Star International Co., Ltd. Device [1462:7721]--00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] FCH Azalia Controller [1022:780d] (rev 01) Subsystem: Micro-Star International Co., Ltd. Device [1462:d721]Which looks familiar but says different stuff than the above. From elsewhere I tried Code:sudo gedit /etc/modprobe.d/alsa-base.conf and added the following line at the end of the file:Code:options snd-hda-intel model=genericStill no sound. How about options snd-hda-intel model=ALC887-VD? Nope. Of course at various times I've Code: sudo alsa force-reload and rebooted at times but still nothing. I'M DYING HERE! HALP!


Post your comments/solution

Get email updates. Virus Removal Tips, News, How to, Threat Alerts.

Bitdefender Antivirus for Mac and PC

Leave a comment!