Welcome to Ebugg-i.com

Thanks for coming to Ebugg-i.com.

Ad blocker detected


Our website is made possible by displaying online advertisements to our visitors. We need to pay our bills (hosting charges) and we can't do that for free. Please consider supporting us by disabling your ad blocker on our website and whitelist our website.
Please disable ad blocker and reload this web page
Close this message

[Answering] There are no log on servers available to service your logon request.

Posted on: Jun 17 2014 Category :Windows > Windows Server General Views: 683 | Subscribe


I have tried EVERYTHING!... heres the situation

1) created a Test Enviro of my working production system, This includes the CA, PDC with DHCP DNS and file services, Exchange Server and a standalone server.

2) Connected all cloned VM's to a TEST VSwitch not connected to any other production servers or even any connectin oto the internet.

3) Since one DC (NOT THE PDC) is physical I manually removed it via ntdsutil, followingthis.

4) Cleaned up all SRV and CNAME records in DNS (_msdcs) etc and removed old DC from all zoned name server settings.

5) reconfigured all NIC settings on CA and PDC to point to DNS requests to PDC DNS role.

6) Power on CA and can't logon with domain creds "No logon servers available"

7) Had a spare Windows 7 VM not in a domain, attempt to add to domain using FQDN Domain.com, failsAttempted to join domain using just domain name... this worked?!?! and am able to log on with any domain account.

8)Log on to CA with local admin, nltest /sc_verify:domain.local -> Fails no logon servers

9)nltest /sc_verify:domain ran on Windows 7 VM just added to domain -> success (leaving me to believe netlogon on the PDC isn't really the issue)

10) (FROM THE CA as a local admin) netdom resetpwd /d:domain.local  /s:PDCname /uD:DomainAdmin /pD:adminpwd -> states kerberos pass reset successfully

11)netdom reset CA /d:cudgc.local /s:PDCname /uO:admin /pO:Adminpwd -> nologon servers

12) start going a bit bananas (I would do the old remove memebr server and readd to fix, but... can't do this as the CA role is installed on this memebr server and won't allow that)

(edited, DNS responds where do to static A records in the parent domain zone)

and the other thing I can't figure out is this (which fails in both my live production environ and my test environ)

netdom query DC -> This works perfect in both environments netdom query PDC -> this fails in both environs(Note I did recently move all FSMO roles from a 2003 Physical DC, to a 2008 r2 VM DC, which included the PDC role)netdom query FSMO reports all correct and is pointing to my 2008 r2 VM DC

Anyone have any ideas as to what could possibly be reporting the removed DC from the DNS lookup on the domain address itself, and what could be casing the PDC query to fail? Why can't I reset the secure connection from my CA to my PDC in my test Environ? Yes I am able to ping all systems in my Test Enivron and there is obivously no firewall in a vSwitch..... I have been bashing my head on this for days!




Post your comments/solution

Get email updates. Virus Removal Tips, News, How to, Threat Alerts.

Bitdefender Antivirus for Mac and PC

Leave a comment!